The Window Menus/Transport Area

Beneath the window header is an area where Bitwig Studio's menus live, along with the transport and its associated displays.

Some of these elements are persistent, and some are transitory. This is a function of Bitwig Studio's unique menu system, which we will examine first.

The Menu System (via the File Menu)

The File menu itself contains only menu items that you would expect and/or those which will be covered in this document at the appropriate time. So we will take this opportunity to see Bitwig Studio's unique menu system at work.

Most items in the menu shown above have four distinct elements:

  • An icon leads each entry, visually abbreviating the function of the menu item.

  • The menu item name itself is always second.

  • When defined, a keyboard shortcut follows. When more than one keyboard shortcut exists for a menu item, the first shortcut is shown.

    [Note]Note

    For information on making or altering shortcut assignments, see Shortcuts Settings.

  • Finally, a thumbtack toggle appears at end of each line.

To anchor an item in the menu area: enable the thumbtack toggle beside the menu item. This will place a button with the menu item's icon beside the menu button itself.

In the image above, three menu items (Collect and Save…, Export MIDI…, and Settings) each have their thumbtack toggle enabled. And now to the right of the File menu are three shortcut buttons, each representing one of those menu items and showing their menu item's icon. Clicking one of these buttons is the equivalent of triggering the menu item.

Like the File menu, each menu button is indicated with a dog-eared triangle in its bottom right corner, hinting that the button can be unfolded. Every menu in Bitwig Studio uses this system, allowing you to anchor any function that you please to the top level of the program.

[Note]Note

If your window is ever sized too narrowly to display all menu options, the program will prioritize by showing all menu buttons first, and then showing as many anchored buttons as will fit the current width.

Transport Section

The transport section appears deceptively simple at first glance.

Let's skip the Play menu for the moment and look at the four buttons that follow:

  • Global Play: Toggles and indicates the state of Bitwig Studio's transport. When clicked to toggle the transport on, Arranger playback resumes from the Play Start Position and active Launcher clips are triggered in sync. When clicked to toggle off, the transport is stopped and the Play Start Position is moved to the current Global Playhead position.

  • Global Stop: Deactivates the transport. When the transport is already inactive, clicking the global stop button returns both the Global Transport and the Play Start Position to the beginning (play position 1.1.1.00).

  • Global Record: Arms all record-enabled tracks. When the global record button is enabled, Arranger recording will begin the next time the transport is started.

  • Automation Write (Arranger) shortcut button: Enables automation recording to the Arranger Timeline the next time the transport is started.

The three global buttons above will always be present. The shortcut button, however, is so named because you can toggle it in and out of existence. This is available for many more transport options within the Play menu.

The Play menu still makes use of the thumbtack toggle convention (when appropriate), but it also makes special use of knobs and other controls. There are five headers within this menu:

  • The Arranger section provides settings that apply when working within the Arranger Timeline Panel.

  • The Clip Launcher section provides settings that apply when working within the Clip Launcher Panel. Note the clip boxes around the icons in this section, helping to distinguish the Launcher functions from similar Arranger functions.

  • The Groove section allows you to activate shuffle for all clips whose own Shuffle parameter is enabled. Other parameters here include the Shuffle amount and interval (Rate), as well as the Accent amount, interval (again, called Rate), and Phase.

    [Note]Note

    All controls in the Groove section can be mapped and/or automated.

  • The Playback section provides parameters that take effect during project playback, such as the Metronome volume, whether sub-beats should also sound (Play Ticks), and the mappable Fill mode toggle, used by Occurrence Operator (see Occurrence) and available via the Globals modulator (see Globals).

  • The Settings section offers a mix of workflow parameters, including Pre-roll controls (for length and whether the metronome should be active), the Default Launch Quantization setting, whether you want a Post Recording Action to be triggered (and if you want a Delay on that action), and whether you want Record Quantization applied to notes (and if so, whether you want their end times to be quantized as well).

Finally, note that Bitwig Studio's audio engine can be engaged for only one Bitwig Studio project at a time, no matter how many are open. So if your current project does not have audio enabled, the transport section will be replaced by a single button.

Simply click this button to rejoin the audible world. (Just realize that this will silence any other project that was previously using audio.)

Display Section

The menus/transport area's display section provides informational meters, numeric controls, and the odd automation-related setting.

This section contains the following items:

  • DSP meter: Displays Bitwig Studio's current CPU usage. (Clicking the processor chip icon on the left will also load a DSP Performance Graph window, including various details and metrics.)

  • I/O meter: Displays Bitwig Studio's current disk activity for data being read (input) and written (output), respectively.

  • Tempo: A control for the project's current tempo, set in beats per minute (BPM).

  • Time Signature: A control for the project's current time signature and an optional tick setting.

    The time signature's numerator represents the number of beats in each bar. Common denominators are accepted (such as 2, 4, 8, and 16), each number representing the type of beat counted in each bar (half, quarter, eighth, and sixteenth notes, respectively).

    The optional tick setting represents the primary beat subdivision to be used across the project (see A Matter of Timing). If only a time signature is set (like 4/4), a default tick setting of sixteenth notes is used. If the time signature is followed by a comma and an appropriate tick value (such as 4/4,8), then that tick setting will be used. Values recognized by Bitwig Studio include 8 (eighth notes), 12 (triplet eighth notes), 16 (sixteenth notes), 24 (triplet sixteenth notes), 32 (thirty-second notes), and 48 (triplet thirty-second notes).

  • Play Position: A control for the project's current play position, shown as BARs.BEATs.TICKs.%.

  • Play Time: A control for the project's current play time, shown as MINUTEs:SECONDs.MILLISECONDs.

  • Restore Automation Control button: Restores control of automation after a parameter is adjusted during playback. The Restore Automation Control button arms itself when the function is useful.

  • Metronome toggle: Enables/disables the metronome whenever the transport is active.

  • Arranger Loop toggle: Activates/deactivates Arranger looping within the Loop Selector's bounds. This toggle together with recording also enables "cycle recording" on the Arranger for comp recording (see Comp Recording in the Arranger ).

  • Punch-In: Causes recording to begin at the start of the Arranger Loop Selector.

  • Punch-Out: Causes recording to stop at the end of the Arranger Loop Selector.

From the Dashboard on the Settings page, the User Interface tab has a Transport parameter that can also Show Loop Region within the display area. This displays the Arranger Loop Selector's start time and length, both to the right of Arranger Loop toggle.

Object Menus

The far right of the window menus/transport area is reserved for the object menus.

Three menus generally appear here, each with their own set of anchored items:

  • The Add menu is always present. It allows you to create new tracks and scenes.

  • The Edit menu is always present. It provides standard "edit" commands for your current selection (like cut, copy, paste, duplicate, and delete), as well as to undo (or redo) recent actions taken across the program.

  • The third menu is a selection-sensitive menu. If nothing is selected in your Bitwig Studio project, then no menu appears here. But if you have selected, say, a Clip or Event, then a menu with relevant functions will appear. This is essentially a context menu with the option to create shortcut buttons (using the menus' thumbtack toggles).

    For example, if we made a time selection, a Time menu would be provided in the third, selection-sensitive slot.

Also note in that last image that when a function is currently unavailable, its shortcut button appears grayed out. As the menu item would appear, so will the shortcut button.

Was this helpful?

Please login to give your Feedback.
Login