The Dashboard

Once you have Bitwig Studio installed and launched, the first place you will land is a place you will return to again and again. The Dashboard is a central hub for finding your projects, configuring your settings, managing library content, and accessing help. Each of these four tasks has its own tab for navigation, and we will walk-through each of them in turn in the following sections.

[Note]Note

If Bitwig Studio opens to a different view, you can call up the Dashboard at any time by clicking the Bitwig logo in the center of the window's header, at the very top of the screen.

User Tab

We call the first tab of the Dashboard the user tab because it displays the name you have registered with Bitwig. (If your username is too long, it will simply display User.)

The Quick Start page shows both Template Projects (that work as starting points) and demo project made either by Bitwig (found under Bitwig Demo Projects) and our partners (under Partner Demo Projects). Each demo project provides a short write-up, a list of any Bundled packages that are required to run it, and an Open button. Clicking Open downloads the project along with any used packages (which requires an internet connection), and then opens the project.

The next three pages show local content and are similar in format. The Recent Projects page shows the Bitwig Studio projects you have opened lately. The My Projects page displays all projects found in the My Projects path (which is defined in the Settings tab within the Locations page), and the My Templates page shows any template projects that you have saved.

Each of these three pages shows content in the same way. A search bar is provided at the top of the project list for winnowing down the projects being shown. When a project is selected (by single-clicking it), project information is display at the bottom of the window. This includes entries such as the last modification time and the file path to the project folder.

To open a listed project: either click the respective Open button or double-click the project name.

Finally, every page under the user tab shares three buttons on the middle left:

  • New Project creates a blank project to let you begin working from scratch.

  • Open File… provides a standard open dialog, in case you prefer locating a project that way.

  • License Info… opens a window that displays your local license data and provides an option for registering a new serial number.

Because exiting the Dashboard requires that you have a project file open, trying to leave the Dashboard with no project open will send you to the User tab. The New Project button politely flashes in this case, indicating the quickest way to exit the Dashboard and get to work.

Settings Tab

The Settings tab is where Bitwig Studio's preferences generally live. We will look at a few of these pages in detail and then take the rest in the order that they appear.

Audio Settings

The Audio page defines a number a of important settings for audio operation, including defining your audio interface and its inputs and outputs, as well as details such as the Sample rate and Block size.

To configure your audio hardware for the first time, begin by selecting the proper Audio System for your interface. The options available here vary based on your platform. If you are unsure of what to set, try the first option available (there may be only one option).

The Input Device and Output Device settings specify which audio interface you will be using for bringing audio signals into and out of the system, respectively. Whether you plan on using audio input or not, you must set the Output Device in order to hear anything out of Bitwig Studio.

Once the Output Device is selected, a section of the window is added with the same name. (In the image above, the driver's output device is named Ausgang (integriert) so a section also labeled Ausgang (integriert) follows.) Bitwig Studio will have created a stereo output pair that is mapped to the first two audio outputs of your interface. In the example shown above, the stereo output created by Bitwig Studio was named Stereo Output is shown under the Output Busses header.

[Note]Note

Names defined in the Output Busses and Input Busses sections will be used across Bitwig Studio to indicate audio routings. These names can be changed here at any time.

For more information, see Multichannel Audio Interface.

The Output Device selected in our case above has only two available audio outputs, and both of those are being used by Stereo Output, as indicated by the checked boxes labeled 1 and 2. The fact that both boxes are checked means that they are being used for the Stereo Output path, which will be available in the program under that name.

Finally, each output path has an assignable Role. The Stereo Output path has been defined as Speakers, making it an option for audio monitoring. The other Role settings are Headphones (also a monitoring option) and Output, which covers anything other than speakers or headphones.

If an Input Device is selected, a Stereo Input will be similarly created from the first two inputs.

Finally, the x button at the far right of each listed buss will delete that path. So if you create a buss by mistake, just click this button.

Controllers Settings

The Controllers page allows you to designate and configure any MIDI controllers that you will be using with Bitwig Studio.

The global Takeover mode setting determines how individual controls and their associate software parameters interact before their values match. Options include:

  • Immediate, which fully applies any control message to its software parameter, moving it immediately.

  • Catch, which waits to move the software parameter until the control message matches or passes the current parameter value.

  • Relative scaling, which moves the software parameter incrementally in the same direction that the control is moving (for example, turning a knob up increases the parameter value, while turning a knob down decreases the value). This creates a relative motion based on your control gestures that will gradually meet the parameter value.

In the Controllers sections, the top row represents ways of adding controllers to your setup. The toggle with circular arrows represents auto-add mode. Enabled by default, this mode will automatically add any detected controller to your Bitwig Studio setup if a device-specific controller extension is also found.

The Add button allows you to add controllers manually. Clicking it calls up a menu of various controller manufacturers, each containing a submenu of models. If you do not find your device here, you can choose the top menu item, labeled Generic, and select the model best approximating your controller. Choices include:

  • Keyboard + 8 Device Knobs (CC 20-27), which is useful for a device with eight controllers that use continuous controller (CC) numbers 20 through 27. These CCs are then used for soft controller mappings.

  • MIDI Keyboard, which is useful for a keyboard controller that you plan to use as a note input device. When specifying the source of MIDI/note messages via an input chooser, you can select all incoming MIDI channels (the default), or you can specify one MIDI channel to listen to.

As shown in the above image with the Korg padKontrol entry, you may see one or more unfilled rectangles with an Add button at the right. These entries appear when a controller that was previously setup and then manually deleted has been recognized by the computer. Since auto-add is not available in these cases, the manual Add button is here to let you quickly restore the device.

Below this top line are entries for individual controllers that are configured, usually named in their title bar with the controller manufacturer and the name of the extension (often matching the controller model). The "power" toggle at the title bar's left edge allows you to disable messages from the controller and extension without removing it. And the x icon at the right is for deleting the controller altogether.

Just below the title bar is a puzzle piece icon with the name of the controller extension (or extension) following it. In the case that you have multiple extensions on your computer that work with this controller, this line becomes a menu, allowing you to swap one extension for another.

On the right side of each entry are menus for MIDI input and output ports (respectively) that the controller extension requires. If a device has gone offline or been disconnected, these ports may need to be set again before the power toggle can be enabled.

Finally, the bottom left of each entry contains a row of buttons related to the controller's performance (see Controller Visualizations, Takeover Behavior, and Documentation).

Synchronization Settings

The Synchronization page provides options for both controlling Bitwig Studio from external sources and for transmitting messages to synchronize other platforms/hardware to Bitwig.

The Transport Sync (IN) section allows you to select the Sync Method in use. The following three options are available:

  • Bitwig Studio's Internal mode keeps the program's clock and transport independent from the outside world.

  • The MIDI Clock mode synchronizes Bitwig Studio's clock to incoming MIDI clock messages from a selected MIDI Input port. For better synchronization, the MIDI Input signal can be shifted positively (to play a bit earlier) or negatively (pushing it later, into the future) in milliseconds.

    Additionally, a vertical orange slider at the far right sets the responsiveness of Bitwig Studio to incoming tempo changes. Moving the slider to the left results in a quicker response to new tempo messages. Moving the slider to the right results is a more gentle response, which can be helpful when the tempo is largely static or the hardware in question is resulting in jittery behavior.

  • Ableton Link connects Bitwig Studio to any and all other programs and devices on your local network that use Ableton's Link technology. (Compatible software running on your own machine alongside Bitwig Studio will be automatically found as well and can be synchronized in the same fashion.)

    [Note]Note

    A list of applications and devices that support Link can be found on this web page. For additional information and support for these other products, visit the appropriate manufacturer's website or support center.

    Link acts as a global time keeper, keeping track of and sharing the latest tempo and relative bar position for all "participants" (each application and device) in a "Link session." The rules are fairly simple:

    1. When a new participant joins a Link session, its local tempo will automatically be set to the Link session's current tempo.

    2. When a participant's transport is started, playback will wait until the Link session's relative bar position matches the participant's starting point. So if you hit play on a participant's transport from the top of bar one, the transport will wait for the Link session to arrive at the beginning of the next bar, thereby keeping everyone in relative sync.

    3. When the tempo of any participant changes, the Link session's tempo is updated, and each participant's local tempo is automatically changed as well.

    [Note]Note

    A general troubleshooting Q&A on Link can be found on this web page from Ableton.

Finally, both the MIDI Clock and Ableton Link options add a dedicated button to the Bitwig Studio window, between the transport and display sections of the menu/transport area (see The Window Menus/Transport Area). These buttons allow you to toggle the selected sync method on and off on the fly, and the Link button also reflects the number of other participants in the current Link session.

The MIDI Sync (OUT) section lets you set whether MIDI Clock, MIDI song position pointers (SPP), and/or MIDI timecode (MTC) should be transmitted to each MIDI destination. Similar to the MIDI Input offset value, a MIDI Clock Sample Offset can be set to fine tune each outgoing path separately. And a global setting for the MTC Rate can be set here as well.

Shortcuts Settings

The Shortcuts page allows the reconfiguration of Bitwig Studio's keyboard commands and the use of MIDI controller mappings to trigger these commands.

On this page, you can Edit shortcuts for both the computer Keyboard and via MIDI Controller.

To define a command mapping: locate the command you wish to map, and then click the + button to the far right of the command. You will then be prompted to trigger the desired mapping.

As can be seen in the image above, multiple mappings can be defined for each command.

To remove a command mapping: click the x button at the right of the mapping.

Once settings have been adjusted, the Choose mappings menu becomes a text entry box where new mapping sets can be named and a Save button appears.

[Note]Note

When this manual refers to keyboard shortcuts, it is referencing the program's default shortcuts. Once you begin using your own shortcuts, the shortcuts in this document may be inaccurate for your use.

Other Settings

All other pages of the Settings tab are listed here in order.

  • User Interface houses settings that visually alter Bitwig Studio. This starts with the Language chooser.

    Device and parameters are still shown with their proper names, but most functions, labels, and Interactive Help (for the 300+ devices and modules) are translated to the language selected.

    This page also includes the selected Display Profile, the program's Scaling level for each display in use, Contrast settings for getting the interface to look its best, the Playhead follow mode for how the window scrolls, and whether timeline audio's Waveform display is shown on a Perceptual scale or not.

  • Behavior contains general settings, such as what to Open on start, whether a Template project should be used whenever you create a new project, and other editing and cache options.

  • Recording provides general Recording settings, what type of tracks Auto-Arm when selected, the amount of Pre-Roll use (and whether the metronome is activated for that period), and the amount (if any) of Record Quantization to be used on notes.

  • Locations defines several paths for Bitwig Studio, such as where My Projects live, where My Library is stored, where My Controller Scripts should be saved, and a number of other locations for the browsers to use.

    The section for Plug-in Locations includes folders to be scanned for valid audio plug-ins, but it also contains preferences for which format(s) should be displayed when a plug-in is located in multiple formats.

    When you have selected to show All plug-ins, the three following options are irrelevant and dimmed. When Preferred formats is selected, the options below take effect:

    • Prefer VST 3 over VST 2 (when available) - When both a VST 3 and VST 2 version the same plug-in are found, this option will hide the VST 2 version by default.

    • Prefer 64 bit over 32 bit (when available) - When both a 64-bit and 32-bit version the same plug-in are found, this option will hide the 32-bit version by default.

    • Show hidden plug-in count in Browser - When the above settings and your Browser's current search criteria result in plug-ins being hidden from view, this option will display the number of hidden plug-ins. And when enabled, this notifications also serves as a toggle, allowing you to click the notification to temporarily show the hidden plug-ins.

    [Note]Note

    All of the above options are applied to both the Browser Panel (see Devices Tab) and the Pop-up Browser (see The Pop-up Browser).

  • Plug-ins provides options for how third party audio plug-ins are shown and handled. For more information, see VST Plug-in Handling and Options.

Packages Tab

The Packages tab is where supported library contents can be managed and downloaded from Bitwig.

The Collections page is a nice summary page, indicating if any of the four collections are available for Install (if they are not currently on your computer), Uninstall (if they are currently on your computer), or Update (if an older version is on your computer).

The following four pages offer granular control of and information for the content within each collection:

  • Essentials Collection is for a basic set of content to run Bitwig Studio. This collection is recommended.

  • Extended Collection is additional content from Bitwig that may be desirable for production.

  • Artist Collection is for content produced by Bitwig-affiliated artists.

  • Partner Collection is for content produced by Bitwig-affiliated partners.

The Package Updates page offers a list of individual packages that can be updated, regardless of which collection they are in.

The program's default behavior is to download package content from Bitwig's servers. If you have a boxed copy of Bitwig Studio and wish to install this content from the included DVD, switch the Install from: menu selection to Choose location.... In the file chooser window that appears, select the Bitwig Studio DVD.

Also by default, the installer places all installed content and other preferences within your current user's folder. By clicking the ellipsis icon (...), a file chooser will appear that allows you to select another location for installation. (Changing this setting will also move any preexisting library file to the new location.)

Help Tab

The Help tab provides links to documentation and resource both within the application package and online.

Again, several pages exist within this tab:

  • Online Help offers information about various resources, as well as either links to the online content or the option to Download & Open Project.

  • User Guide provides links to this document in all available languages.

  • For Developers contains links to various guide and references documents and other on-board tools.

  • About presents the version of this Bitwig Studio installation. It may be useful for bug reporting, etc.

Was this helpful?

Please login to give your Feedback.
Login